SQLAlchemy 2.0 Future (Core)

This package includes a relatively small number of transitional elements to allow “2.0 mode” to take place within SQLAlchemy 1.4.

In the 2.0 release of SQLAlchemy, the objects published here are the same Engine, Connection and create_engine() classes and functions that are used by default. The package is here for backwards compatibility with SQLAlchemy 1.4.

The sqlalchemy.future package will be deprecated in a subsequent 2.x release and eventually removed.

See also

What’s New in SQLAlchemy 2.0? - Introduction to the 2.0 series of SQLAlchemy